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Express Tools

The GstarCAD Express Tools contain a library of productivity tools designed to help yafuyextetesiga. power
They are easy to use, easily integrated into your menus and toolbars, and cover a wide range of functions, includ
dimensioning, drawing, and selecting and modifyirtgstdj€éd. Express Tools are organized on:

1. Block Tools

Change basthe CHANGEBASE command allows changing
the base point position of a block. You can move the bas@\_‘ T
point and keep objects staying in same position, or move' - s PO ] N

objects and keep base point staying in same position l_.. ) s
- I H
[ l |
]

MenuExpress tools>Blocks>Charage B e T L —

Command Entey4ANGEBASE

Block BreaWorking with block references that represent symbols are essential in some industrial application dra
like electrical schematics, piping, etc.

But a headache comes when try to place these blocks accurately overlapping or even braakiogr other objects
drawing.

Now get rid of this headache with BLOCKBREAK command. This innovative tool is able to wipeout or breaks an «
is overlapped by a reference block.

For example, insome cases we may need to insert block symbols intolectaddd dickeeimatic. And normally

the cable line is required to be broken by the symbols at where the symbols are inserted. Similar request are also
other application designs.

Menu Express tools>Blocks>Block Break
Command EnBy:OCKBREAK

Block break dialog box:

Name:List all available blocks created in
drawing. Name: |EiEeneem [« [(Bowse. | [ Pk ]
BrowseBrowse to open specific drawing file.
PickYou can pick an existing ldferemce in the
current drawing.

ScaleScales the block reference size accort
X, Y and Z coordinates. Uniform Scale optic z [

the original size of block reference. B S /] Break [ Sheter
RotationYou can rotate a block referenc

inputting an angle value or kgegdli [ Insett block | [ Select insetted block | [ Cancel
Process Mod¥ou can use a block reference w

break or wipeout objects when overlapping.

Scale Rotation

Angle: [¥] Aligned

Process mode




Block Break Process Mode lllustration
BreakBreaks background object(s) when a block reference is overlapped.

Y
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DOUBLE BED

Replace Bloekth Another Blockthe current drawing, you can use
SOFA

one block to replace anottevloreoveyou can purge the

unreferenced block when the operation is finished.

Menu:Expresstool8tocks>ReplaceBlock
Command EnByOCKREPLACE

Select a block to repoeble bed. Then select: OK Select a block tareplace
Select the block to be replSofal Then select: OK Sefa
Purge unreferenced items when finished? Yes/No

[ Picke | Doublebed1

| ok [ cancel

Select the block to be replacedDouble bed

Double bed 1

See the result below:
DOUBLE BED

[ Cancel




Copy Nested ObjeCopy objects imaef or a block.

Menu:Express>Block€opy Nested Objects
Command EnttyCOPY

Command line prompts as follows:
Select nested objects to ddsgan object selection method

Base poinSpecify a point, or enter M for multiple copies
Specify second point or <use first point as displac@peeifira point

Explode Attribute to Explode blocks, converting value of attributageotsex

MenuExpress>Blocks>Explode Attributes to Text
Command EntBURST

Command line prompts as folleves:t entitiddse an object selection method
For example: Explode attributemnaed them to text objects.

1. Select a block containing two attributes 2. Block exploded and attribute values converted to text.

t J Enter number {
: 1238668944 | |

Attribute IncreméiETINC command helps to specify attribute of blocks with incrementalodify ettaitbd o
value of blocks according to the sort method.

MenuExpress>Blocks>Attribute Increment
Command EntATTINC

This command can increase block attribute value that containsttenuviben &TTINC command is on, as long
as the drawing is not closed, when copying, inserting and deleting a block attribute in the drawing, the property
or letter can be updated automatically.



2 —
G Attribute of the block
@7 (T seectthe «k(E): | _TagCircle ~| [ Parameter
Select the attribute @ Inerem O Add Ration
sign value Increment [— 3
TAGNUMBER A v
Incresse the last numb
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oK Cancel Help
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T c
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Export Attribute Inform&kpolock attribute to an external filediglitalted ASCII format.

Menu:Express>Blocks>Export Attribute Information

Command EntyTTOUT

Once performed ATTOUT command, specify file name antEsssequétiifilename™ dialog box, then
command line promptdect entitieSpecify the blocks whose attributes you want to export.

The block names and attributes are export
the named file. If the file already exists, yol
prompted before igrwritten. You can easi
view attributes in a spreadsheet format anc
individual attribute values. Then you can e
new values into the drawing file, using the
command.

« DRA.. > DWG FOR THE SALES STAF.

Enter number

1238668944

New folder

Import Attribute Informétiqport block attribute texaernal file intdélimited ASCII format.

Menu:Express>Blocks>Import Attribute Information

Command EntyTTIN

Using ATTIN and ATTOUT together, you can quickly make changes to attritietbhlaklesferesates.

Once this command is perforn

¥ Enter input filename

- » Favorites

n
the "Enter input filename" dialp

Enter number

H Organize v

1238668944

- Favorites
B Desktop

will pop up for the user to search
file, import the block attributes
along with the same handle and

block name into the drawing, and
make changes to the block

attrilites as well.

% Recent Places

4 Libraries - Shortc| = l
18 Downloads

A Libraries
5 Documents
& Music
& Pictures
B videos
Sl RETE

Once an attribute value is

438 bytes

File name: PHONE ATTRIBUTES DISPLAY v | Txtfiles (.bd) Z
Tt files (*.bd) Ls

Desktop
Shortcut

Downloads
cut

Allfiles ()




modified, it will be integrated into the specified block. It should be noticed that the imported file can't be attribute f
exported by ATTOUT command, whereas the file format should be identical cortirabotiAAKpGting.

Reads through imported file and processes each line when performing ATTIN command. If the block with the san
handle and name is found in the process of treating lines, the modified attribute value of this block will be applied.
several blocks with the same handle and name are found, then system prompts whether to interactively assign sa
data when processing these blocks. If "Yes" is selected, the data of each command line will be listed enabling sel
of a block to applig thitribute. Press ENTER to skip to next line, press ESC to exit.

Edit Block Attribute in PRllmws you to edit the textual contents of an attribute of a block when you feel like editir
the attribute values without accessing the attribute editor.

Menu:Express>Blocks>Edit Block Attribute in Place
Command Ent&TTIPEDIT

Statistics Blocks NumYaeu: can statistics the quantity of various blocks through this function.

Menu:Express>Blocks>Statisitecks Number
Command EntBLKNUM

Once this command is performed, its dialog baxpailhgep Stat. Condition, you can input a block name, layer or
check the options: Ignore the blocks in the Hgpo@iresed also ignore the scale.

Stat. Block quantity @

Stat. Condition:

Black Name ‘ ™ \ ]
S ———| >
[ Layer 1 \
Ignore the blocks in the same
M insert point.
Ignore scale<= \10 Blocks

5 o




Menu:Express>Blocks>Count Bloc'~
Command EntBCOUNT

. 1
Operation steps:

1. Start the command, the commair .
linepromptsEnt er to s
or ...0. :

2. You can press enter to select all | —

blockswithin the drawing or by ”

selecting blocks.

3. Once pressing OEnterdé the system wil!|l di spl ay

>

1

Change Block Cdutodify the block coldckiy.

MenuExpress>Blocks>Change Block Color

Command EntbChgCol @ @
Operation steps:

1. Start the command.

2. Input new color number, here we input 30 for example.

3. Select block objects, for which the color needs to be changed.‘
4. Finished modifying.

Change Block Linewitils function can modify block linewidth quickly.

Menu:Express>Blocks>Change Block Linewidth
Command EntbthgWid

Operation steps:

1. Start the command.

2. Input a new line widthe.

3. Select block objects, for which the line widths need to be changed.
4. Finish changing the line width.

Change Block Texgl&This function can change the text rotation angle of the blotikasdeff@rtlyn text or
mtextat t ri bute text canot be changed.

Menu:Express>Blocks>Change Block Text Angle
Command Enth€hgAng

Operation steps:

1. Start the command.

2.Input new text angle(comparative)witt @put 0.
3. Select the block to change textthegl8elect objects: G S ‘t QL [: A D
4. Finish changing the text angle.

t



Change Block Text Higis: function calmange the height of the block, it only takes effect on text or mtext, attribute
text candt be changed.

MenuExpress>Blocks>Change Block Text High
Command Entr@hgHei

GstarCAD

Operation steps:
1. Start the command.

2. Input a new text height value.
3. Select objects whose text heights need to be changedG g At Q }/\ C A D

4. Enter to finish the command.

Change Block Lajhis function can change th
block layer. ‘

MenuExpress>Blocks>Change Block Layer

Command EntbChgLay

Operation steps: \“
p p \

1. Start the command. 4
2. Input target layer name.

3. Select block objects to change layer.

4. Press Enter. If the target layer exists, the selected block will be moved to the target layer, if th&arget does not e
software will make a new layer automatically and move the block object to the new layer.

Convert BLOCK to XRegitace all instances of a stand®d P
block with an xref. Unbind xrefs that are bound. X

S
START TREKVIEW
Tatio3

e o hor
Tetie wsbily
e
TREKBLK
Washing bssn

Paoks. Table and 4 chars
=] Coma)

Menu:Express>Blocks>Convert Block to Xref
Command EntBL.OCKTOXREF l

-BLOCKTOXREF sedhehestire drawing for references to a specified block name and replaces them with an xref ti
you specify. You can have the unreferenced block purged when done. In BLOCKTOXREF dialog box. Select a bl
replace: Table and 4 chiien sele@kbuton.

e i
-In Select a Xref file. Select the Xref you wapt::Then i == '
select Open button. ,q ) 5 ﬂ]
Purge unreferenced items when finished? V] sto ,; =




List Xref/Block Propeitistthe type, block name, layer name, color ard dredgped object in a block or an
xref.

Menu:Express>Blocks>List Xref/Block Properties
Command EntXLIST

Command line prompts as félloact nested xref or block objecUselist
an objectelection methddter selecting an external reference, the "Xiif/Bloc
object" dialog box will display attributes of specified blocks and xrefflincluc
object type, block name, color and linetype.

Object: LINE
r 2z

Color: Bylayer
, Linetype: Continuous

Trim to Nested Objélrims objects with a bloclcatting boundary.

Menu:Express>Blocks>Trim to Nested Objects
Command EntBTRIM

Command line prompts as follow:

-Select objects or <select aSelect one or
more blocks and pieSS ER.

-Select the object to Trim os8leitt to
Extend or [Edge/Fence/Crossing/FBelect]:
object(s) or enter an option and press ENTER

Extend to Nested ObjExtends objects such as line segmealylare,qr ray to a block. Objects would be
extended to a block as close as possible if they cannot intersect with each other.

Menu:Express>Blocks>Extend to Nested
Objects
Command EntBEXTEND

Command é&rprompts as follow:

-Select objects or <select aSelect one or
more blocks and press ENTER.

-Select the object to Extend eseddnittto Trim
or [Edge/Fence/Crossing/PrSelgtt object(s) or enter an option and press ENTER.

External Reference RelWditlicthis function, our softwar

can recognize the reference in ting drahgive you the | ==re —

reference state, if you want to select another reference pathe: e e R
click the ORelocatedé butfton and the referenfce
in the drawing again.

Menu:Express>Blocks>External Reference Relocate
Command EntGHGXREFPATHa < 3

[HelalivePalh] [ Relocate ] [ Exit ]

10
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Operation steps:

1. Start the command and a dialog box will pop up.

2. Select theternal reference name which you want to modify.
3. I f you click the ORel ati
system will relocate étxternal reference.

11
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2. Texfools

Justify Tex@hange a text object's justification without changing its position. Works with text, mtext, and attribute
definition objects.

Menu:Express > Text Tooldustify Text
Command EntiduUST

Select objecttlse an object selection method.
[Start/Center/Middle/Right/TL/TC/TR/ML/MC/MR/BL/BC/BRheBteitiie new justification

Usage Example: Coserto middle justified

-Text left justified. -Text after justification change.
TEXTOUTLINE  ~ " TEXTOUTLINE
EXPLODE EXPLODE

Rotate TeAligns text, mtext and block attribute objects to new orientation. Rotates text, mtext, and attribute defini
objects sthat they end up being as close as possible to horizergatl dsingiler to the behavior of dimension

text). Objects are rotated about their middle palegired &icrements. For example, if the textdewpsitie

becomes rigbide up &r a TORIENT operation. Similadgdlefikt becomes Higad text.

Menu:Express > Text Tools > Rotate Text
Command EntiyORNET

7 e 2 e X Thig ig. text
i ; . o e 2 xgt This 15 Jethis 18 text
-Select objectse an object selection method ¥ s,z;&v-&i\‘\\e 8 This is text  This is text
-New absolute rotation <Enter a new absolute orientatio:* * =4 ;::s B e e text This is text
. N o
angle for all selected tesage ExamplEext before rotation e~ r > e ¥ oy, This is taxt  This is text
. . . Cw This j3. teltig i text
(Fig 3) -Text adt rotation specified angle of 0 £ & % This "5 e

degrees (Fig 4)

Change Text StVhis function can change current text style for specified text and singleértexexgrmultili
available.

Menu:Express > Text Tools > Change Text Style
Command EntGHGSTY

Operation steps: . Sl -TeX t

1. Starthe command.
2. Select the text to change text style and you can modifygtisimt fee et et e

Command.

objects at a time. Then Press enter to finish the comman s sy sse cme:

and.

12



Chinese Characters $hig:functiaran split single line texts to single text one by one, because the English word is a
combination of several |eft@ssfunction only magesse for Chinese Characters.

Menu:Express > Text Tools > Chinese Characters Spiihmand EntiZCF
Operiion steps: Xt ; eX '
1. Start the command. u -
2. Select the text to be split. Commas

3. Press enter to finish splitting. et oy

[Command =D

Character BreaMenu:Express > Text Tools > Character BZeakmand EntkiZDD

Operation steps:
1. Start the command. 2. Select the text to break. 3. Specify the position for the break.

Change CharacThis function camtiouously revise multiple text objects, single line and Mtext are applicable.

Menu:Express > Text Tools > Change Character
Command EntnDDEDIT

Texx

1. Start the command. T

Command!

2. Select the text to be replaced. Commend._DDEDIT

Select an annotation object or [Undo].

3.Input characters to replace and press Enter to finigh, et enemasion ke orlindl 3

Change One Charariis:function can change texts in selected single line texts, you can just input characters to be
repaced and characters to replace according to the prompts, Moreover it can be used in several single line texts
same time.

Menu:Express > Text Tools > Change One Character
Command EntGHGTXT

Operation steps:

1. Start the command. Text m
2. Select the text to be replaced. Command Line

3. Input the characters to be replaced. ommand: CHGTXT

Sedect the text to be replaced
Select object: Spedify opposite comer: 1found

4. Input characters to replace. l5etect object
.. input the characters to be replaced-ext
5. Ress enter to finish. rpi chamcters o replace:00l
Changed 1 rows.

13



Change Text Height/Width/Angle/Pilsisidunction is used to modify text height, text width, text angle and text
position. You can click or select characters by window selection.

Menu:Express > Text Tools > Change Text Hafighitf\ylie/Position
Command EntiyXTHEI / TXTWID / TXTANG / TXTPOS

Delete Annotatibhis function is based on this kind of circumstance, you can select one text annotation to be delet
the softwavell register all the annotations in one layer, you can just press enter and all the text annotations will be
deleted or you can select the texts by window selection and it will not affect the texts of other layers.

Menu:Express > Text Tools > Deletet#imm
Command EntZOFF

Operation steps:

1. Start the command.

2. Specify a text annotation to be deleted. At this time you only specify the operation layer, if yohelirectly press er
entire layer single texts will be deleted.

3. Select annotations to be deleted (you can select several objects by window selection) and press enter to finish

Adjust CharacWhen the texts are mixed with Chinese characters, English letters and Arabic numerals, the text he
willbe different and the visual effect is not good. You can use this function to match the text height, but this functic
explode the text's and it will be difficeltlity $6 we suggest using this function after the user finished editing the
drawing

Menu:Express > Text Tools > Adjust Character G Sta rC A D

Command Entiiyf L2
GstarCAD

Operation steps:

1. Start the command. : e

2. Select the text object which needs to adjust the heighg® = ;:;e:ft object to need repair the charater high :
3. Press enter to finish.

Command :

1465.2982, 587.3208, 0

14



3. Layout Tools

Align Spacé&djust the zo@and pan factor of in the layout viewport based on the alignment points specified in th
model space and paper space.

Menu:Express > Layout Tooldign Space

Command EntALIGNSPACE

List Viewport 8c®isplays the scale of the current viewport or of a selected layout viewport.
Menu:Express > Layout Toolsst Viewport Scale
Command EnttfPSCALE

Synchronize Viewp&ysachronize one or day@ut viewports to a master layout viewport to have the exact locations
matched up. All synchronized viewports use the zoom factor of the master viewport.

Menu:Express > Layout Too&nchronize Viewports

Conmand EntryPSYNC

Layout Mergderges specific layouts into a single layout. All layouts or model are available to be picked, and you
specify an existing layout or enter a new name to create a new layout as the destination layout.

Menu:Express tayout Toolscayout Merge
Command EnthAYOUTMERGE

15



4, Dimension Tools

Area TablAREATABLE command automatically dimension and count the area of anenclosed object and export th
to a table in the current drawing area.

Menu:Express>Dimension>AreaTable
Command En#jREATABLE

The enclosed area or object can be markednbéh @ mrea symbol, and the area table data can be generated at the
same tim&he area data can be exported to a text orTtadlediiles in the table can be changed automatically

when the number or area size is changed.

P A2 zx [I] ﬂ; @ |:m‘ v_"f b @ 2z
A T o x e
Y 2 4 3 = |lE & : I
Text Copy  Summal stion ine Break Increment Blocks Table Coordinate Point Object Hatch Coordinate | Compare Compare
Madify

G AreaTable

[~
Border
Text Settings
®omarea

Text Style:
Text Height:

Text Location:

Start Number:

—hzg wresprei

[# Pk

T#|  selectobject

Output

ot e output

O oim Number

Standard v

Area Suffix:

Number Prefix:

m:

LA

C:\Users\win 10\Desktop\AREA TABLE.tet |,

Table Settings
Create Table
Assodiate Number
Calaulate Sum Area
Table Style:
Title:
First Header:

Second Header:

Transform Units

Units From:

Standard v

Area Table

Square millmeters

T . Units To: Square meters ~ Area Tabl e
Ratio: 1 Number Area
1 7.104m2
Y e e s 2 13.806m2
‘ /\ % A Sum area 20.910m2

Rapid Did¥leasures distance and angle between 2D objects along X, Y axis rapidly by moving mouse.

Menu:Express>DimensiofRapid Dist
Command EntRAPIDDIST

Distances that only can be measured adoig)
based on the position of your mouse, are dif
dynamically as you move your mouse OW
between objects. Angles between the
touched by distance lines, are disp
dynamically at the same time. E5
The command only can be used undenWg€S;

bl ocks canot be measured.

16



Type® S e t ,tydurag sebunit conversion and scale in - g ¢ %
setting window.
< , . Scale, Annotation  Scale 1 1|10
Typed R e ¢ youcdndsave the current result in command line P
. . . . Unit Units From cm ~ Convert To ii_[]_ch ______ ~
window, which is convenient t&k arecopy data to other
documents.

Change Dimension Ghange the dimension content into the specified value.

Menu:Express>Dimension>Change Dimension Text
Command EntG§HGDIMTXT

Q) 90

Commanithe prompts as follows:

-Select dimension objeSétect a dimension

-Currently label content <129.9>, input new dimension text
<practically measure dimensidiype a nexalue (130)

130

Change Dimstygply the current dimension
style to the dimensions in the drawing.

Menu Express>Dimension>Change Dimsty
Command EntBimstyle

130

Reset Dim Text V&Restora measurement value to overriddenor " "=
modified dimension text. . A e

AT By N / \ \ /7 O\

(D) L BED)

Menu:Express>Dimension>Reset Dim Text Value Nl A D 7 ”
Command EntjtMREASSOC Bt

Command line prompts as folleves:t objecSelect dimension
objects with n@ssociative text or press ENTER to quit 12122

17



Update Dimensidpdates any other dimension(s) to the current dimension style you want to apply.
Menu:Express>Dimension>Update Dimension
Command EntIMUPDATE

Command line prompts as follow:
-Select a dimension for starSelect a dimension as a base.
-Select a dimension, engpdate the dimension Sglect dimension(s) to be update.

’/\-\ /\H
|

f/ ) 1,004
\\ "
\R0.9877
Dimension
| Standard | 130

Dimstyle Expd&kports named dimension styles and their settings to an external file.

\R0.9877

Dimension to be
Updated

Menu Express>Dimension>Dimstyle Export T 5
Command EntBtMEX Evpot Flenane = ]

Drawing1.dim Browse...
—

Available Dimension Styles

Executing this commataalts the following dialog box
Export FilenarGeeates a DIM file. Enter the DIM file name or select Browse
the file. If the file does not exist, it is created. If the file does exist, a promf e

permission to overwrite. The new file is an ASCII file. = il el

Available Dimension SSetects the dimension styles to write to the ASCII fi

current dimension styles are displayed. Each selected style is written to the file indicated in the Export Filename ¢
Text Style Opti@aves either the dimension's Full Text Style
Information or the Text Style Name Only to the ASCII file.

NoteDimstyles are created and saved with the DDIM com:

. \
must select at least one Dimstyle for thie &epsuccessful. e

Dimstyle Impdrnports named dimension styles from a DIM file into the current drawing.

Menu:Express>Dimension>Dimstyle Import
Command EntBtMIM

Executing tkemmand, starts the following dialog box:

18



Import FilenanNames the file you
want to import. Enter an existing fil
name or select Browse to specify ¢
file to import. The file must be of th
form generated by the correspondi
DIMEX command. All akioe styles
in the selected file are imported into the
current drawing. Text styles are also imported.

Dimension Style Import I =5

ing Style

Overwite Existing Style

Import OptionacludeKeep the Existing Style, to keep the dimension style in the current drawing and Overwrite
Existing Style, to overwrite styhes¢urrent drawing. The Keep the Existing Style option ignores the similarly named
style being importé&erwrite Existing Sigés the similarly named style being imported.

Attach Leader to AnnotAltaich leader line to Mtext, tolerance, or block

reference object.
) Use the QLATTACH

command to attach

Menu:Express>Dimension>Attach Leader to Annotation leaders to Mtext
Command Ent@t ATTACH

-Select Lead@Select a leader /
-Select a dimensi&elect the Mtext, tolerance, or block reference object’... ...

annotation

Usage Example:

-Select a leader, and then specify the Mtext object to attach.
-Separate leader line and Mtext objects.

-Leader line with mtext attached as one object.

At theselect Leadprompt, you will be prompted until you select a leader object or abort the command.
At theselect Annotatjrampt, you will be prompted until you select an MText, TolerancegincdtdgjkdRefer
for the annotation

Detach Leaders from AnnoDRetaich leader line fnatext, tolerance, or block reference object.

Menu:Express>Dimension>Detach Leaders from Annot@tommand Ent@t DETACHSET

-Select objeciSelect leader line. )
WITHOUT Leader line

Leader line
Usage Example:
-Select a leader line to detach from an mtext object.

19



Global Attach Leader to Ann@@iobally attaches leldesto mtext, tolerance, or block reference objects.

Menu:Express>Dimension>Global Attach Leader to Annotation
Command Ent@t ATTACHSET

-Select objec8elect one or multiple leader lines and annotation

objects

MTEXT
Usage Example: /
-Select leadéne(s), and mtext objects to attach.

-Select objectSelect one or multiple leader lines and annotat

objects, the command line prompts: Number of unlocked IHaddrsr=n&th annotatiomhiets= 2
-Leader with detached Mtext object (Fig 5)

-Leader attached to lb@c(Fig 6)

20



5. Selection Tools
Get Selection SErieate a temporary selection set of objects.

Menu:Express>Selection>Get Selection Set
Command EntyETSEL

-Select an object on the Sourcelsgea:selection set method or press ENTER for all layers.
-Select an object of the Type yoWseatselection set method or press ENTER for all object types.

Fast Sele@elects the object that touches the specifide object.

Menu:Express>Selection> Fast Select
Command EntRASTSEL

You camput FASTSEL command to select all objects that touch the selected object immediately.

Command Line

Command: [FiyE=8

Use 'FSMODE to contreol chain selection.
FSMODE = ON. W
Select touching object: < >

Supported objects include: Lines, polylines, circles, arcs, attribute definitions, text, Mtext, ellipses, and images.
FSMODE: Controls two behaviors of E&8iralaH, default value is OFF.

If FSMODE is turned OFF, when you execute the FASTSEL command, it selects only those objects that are toucl
selected object.

If FSMODE is turned ON, when you execute the FASTSEL command, it setbetisea# thedbjerthe
selected object, as well as any objects that are touching those objects. The selection process of all unselected to
objects continues until there are no more unselected objects visible in the drawing area.

Filtrate SelectiSdect, edit, and name filters for object selection.

Menu:Express>SelectiorFitrate Selection o . ==

Command Enthjlter %‘
Select Object Filter dialog box Options: : - - E

Named Filters

1.X, Y, Z ParameiBefines operators such as < (les|| . - = L

fomed ]
additional filter parameters than) or > (greater than), e
depending on the object. In the filtér SelecDisphys adialogﬂ [om ] (G ] [t ]
parameters, you can use relative box listing all items of th

21



specified type in the drawing. Selefiter property into the Select Filter properties are loaded from the

the items to filter. area for editing. To edit a filter default file, filter.nfl

3.Add to LiAdds the current propertyselect it and choose Edit 11.Save ASaves a filter asd i
Select Filter property to the filter listem. Edit the filter property and list of properties. The filter is saved
Filter properties that you add to thehoose Substitute. The edited filtein the filter.nfl file. Names can
unnamed filtenmain available replaces the selected filter propertgontain up to 18 characters.

during the current work session 7.DeleteDeletes a selected filter 12.Delete Current FilterDeletes
unless you manually delete them. property from the current filter.  a filter and all its properties from the

4. ReplacdReplaces the filter 8.Clear LisDeletes all the listed  default filter file.

property selected in the filter properties from the current filter. 13.ApplyExits the dialog box and
property list with the one displayed displays the Select Objects prompt,
in Select Filter. 9.The filter name is uBisplays,  where you create a selection set.
5.Add Selected Objdds one saves, and deletes filters. The current filter is used on the
selected object in the drawing to tH&®.CurrenDigplays saved filters.  objects you select.

filter list. Select a filter list to make it current.

6. Edit ItenMoves the selected The named filter and its list of

Get Selection by Block N¥me:can use this function to-swmleltit
objects with the same niarsgecified area. *

Menu:Express>Selection Tools>Get Selection by Block Name
Command EntyETBLKSEL

Operation steps:

1. Start the command.

2. Select object, specify a block name for operation.
3. Specify the region.

4. System will bring all the blocks with same name in region selected area into the selection.

Get Selection by Object Yguecan use this function to
multiselect objects with the same entity type in specified area.

Menu:Express>Selectibools>Get Selection by Object Type

Command EntyETENTSEL
Operation steps:

1. Start the command.

2. lect object and system will take the specified entity type as
target type. Then specify region. .

3. System will bring all the blocks with same entity type in re
selected aento the selection.

[Select object:

[Select objects with windows: <Erter for select all>
[Please select Entity Object:

Please inpu the sencond comer: 92 Entities have been selected
/85 entities have been fitered

Please select Entty Object Cancel”

Command: Cy ]
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Get Selection by Layeu can use this function to select all the objects in specified layer and specified region at c
time.

Menu:Express>Selection Tools>Get Selection by Layer
Command EntyETLAYSEL

Operation steps:

1. Start the command. _
2. Specify an entity which is tattet layer, then specify region:=*
3. System waklect all the objects in specified layer and spemss
region. . ".j;'

Prasss synt o st comas 91 irotes e o sbersad
P rratern = avre e et

v

Get Selection by CQuiick select the objects with the same color.

MenuExpress>Selection Tools>Get Selection by Color

Command EntBETCOLSEL

Operatiasteps:

1. Start the command.

2. Select one object andetcwlgrstem will take the obje
3. Specify region.

4. System will select the objects which have the same color as the target object automatically.
CGet Selection by Object/Layer: Select entities by entity type and layer.

Menu: Express>Selection Tools>Get Selection by Object/Layer

Commancdiy: GETENTLAYSEL

Operation steps:

1. Start the command.

2. Select one object and system wiiletakgett layer as target layer.

3. Specify region.

4. System will select the objects which are in the same layer amdityitiisameaomatically.

Get Selection by Object/(Sgtect entities by entity type and color.

MenuExpressSelection Tools>Get Selection by Object/Color

Command EnBETENTCOLSEL

Operation steps:

1. Start the commhan

2. Select one object and system will take the obje
3. Specify region.

4. System will select the objects which have the same entity type and color as the target object automatically.
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Get Selection by Layer/(Sglact entities by color and layer.

MenuExpress>Selection Tools>Get Selection by Layer/Color

Command EntBETLAYCOLSEL

Operation steps:

1. Start the command.

2. Specify an entity which is in the target layer.

3. Specify region.

4. System will select the objects which have the same color and same layer as the target object automatically.
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6. Modify Tools Coye Drow Orcer

Layer List Layers to Adjust Draw Order

LayeDrawordeRearranges the layer order to adjus

sequence of the objects. +
++ 4+

Menu:Express>Modifykayer Draworder —+ i

Command EnthAYDRAWORDER -

Mame: [ | Bring to Front Send to Back

Draworder by Coloranges the drawing order of selected objects by their color number.

Menu:Express>ModifyBraworder by Color
Command EntyDORDER

came from this kind of needs.

Break Objedn some industrial application degmw%?ﬁl _ S o > I Dy e
sometimes we need to break pipes or cable lint Ui: T3 ° o
schematic drawing to indicate their spatial relais_* ; S —
Sometimes we also need to break lines at cross L L & e NEE
to make it convenient for the later ed@hreatool @DI?E‘E le e Y

|

1 COLD WATER
BOILER MAKE UP

Menu Express tools>Modify>Break Object
Command EnBREAKOBJECT

This tool provides four breaking modes with gap distance to visaatizs thetwéd&ar breaking options.

Gaplndicates the gap value between broken objects
Break all objects selected with eacfhighaption breaks all intersected objects each other. You can select objects by
window selection or picking each object.

Break selected objects with other selected| & ‘BreakObject
This option breaks all intersected objects
selection sets (A and B). The objects s¢ Gap:
under the first set (A) will be broken meg >t /P ofBresk Function needed:

the objects selected under the second [

100

Break all objects selected with eatch other J

will be ndtroken. [ Break selected objects with other selected objects J
Break objects touching selected oHjist
option breaks all intersected objects thal

[ Break objects touching selected objects ]

at first instance selected object. [ Break selected objects with.any.objects that touch it ]
Break selected objects with any objects th
it: This option breaks the first instance s¢

object with afitersected objects to it.
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Move/Copy/Rotdeve, copy, rotate, and scales object(s) with a single command.

MenuExpress tools>Modify>Move/Copy/Rotate
Command EntOCORO

Command line prompts as félioact objecSelect object(s) and press Enter
Base poirBpecify a base point
[Move/Copy/Rotate/Scale/Base/Undo]<@née-an tipn is specified

B x
/\‘ IEI

Options MoveMove
object(s)CopyMake multiple copies of objegti{s)icRotate object(SktaleDynamically scalgech(s)Base:
Specifies a base point for object(s) to be moved, copied, scaled or rotated.

Region ScaMou can select a region of a drawing to be cut and copied to a new location.

MenuExpress tools>Modify>Region Scale
Command EntiREGSCALE

Command line prompts as follow:
Specify left up corner point fpadelprocSelect a region from left ur
to right down corner

O

DETAIL

=

REMARKS

BOLTS, NUTS, WASHERS AND CIRCLIPS
SHALL BE BORNE BY THE MANUFACTURER
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Select the object to Trim esslat to Extend or [Edge/Fence/Crossing/Project]: / \
Select objects to trim or press Enter to finish the operation. : i

Input zoom soglithe block and text will zoom togetherdEAtEM>Press Enter to e
finish the operation. / \

Trim Enhancemdrim one side of an object which is intersecting with other objects. The object can be polyline, li
circle, arc, ellipse, image or text.

MenuExpress tools>Modify>Trim Enhancement
Command EnfEXTRIM

Operation steps:

1. Start the command.

2. Select an object as trim reference, here we select the rectangle for example.

3. Specify the side to trim on.

4. Here we select the internal point of the rectangle, you will see that the internal lines of the rectangle are trimme

Extended Offddiis enhanced version of the OFFSET command offers several advantages over the standard comr
including layer control, undo, and a multiple option.

MenuExpress tools>Modifyxtended Offset
Command EneXOFFSET

1 Specify offset distance or [ThroughSpeéeify the offset distance or through point
2 .Select object(s) to offset or [&phmiv|Select an object to offset, change options or undo
3 Specify an option to set [Distance/Layer/Spetifyean option
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EXOFFSET Options:

Distance&Specify the offset distance or through point

LayeiSpecify the layer for new objects. Current Layer or Source Object Layer

GapTypSets or changes theebfhode as controlled by the OFFSETGAPTYPE variable. The options are: Normal, F
or Chamfer.

Normal / / Fille/t/,»'” /Chamf/er'/ '//
\\ ]\ \
Distance Layer GapType

Multiple Pedifhis command is almost the sametandaed command.

MenuExpress tools>Modify>Multiple Pedit
Command EntdPEDIT

1. Start the command.
2. Select object
3. Specify an option tgdGSetkn/Close/Decurve/Fit/Lirmatyge Spline/Width/eXit]<eXit>:

Example to close plines:
1. Select objeselect plines which you want to close.

.

2.Open/Close/Decurve/Fit/Lirmatge Spline/Width/eXit|<ekiput keyword: C and enter.
3. You will get the plines closed.

Extended Cl@ip images, xrefs, wipeout, or specified parts of block objects using circles, arcs, ellipses, or text
boundaries

MenuExpress tools > ModiffExtende@lip
Command Entey:IPIT

The regular clipping (CLIP) command does not support clipping raster images with circle, arc, or ellipse boun
while the CLIPIT command supports clipgasg xmefs, wipeout, or specified parts of block objects using circles,

arcs, ellipses, or text as bouraladigeu can set the maximum error distance of the curve approaching.
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Delete Duplicate Objethis: function can not only manage ovéneappeictles, Plines linear objects etc, but can

also manage entire coincident blocks, texts, dimensions and regions .Moreover, remove does not simply mean de
judges by layer, color, line type and many relevant attributes and can dedéteidenbpags of 2D and 3D

Plines, circles, arcs and overlapping line parts. Using this option can not only delete redundancy objects, but can
avoid editing and printing problems caused by overlapped objects.

MenuExpress tools > Modify > Ddleiplicate Objects
Command Ent)/ERKILL

Start the command and the command line promptSaie foliove c8elect the objects to be compared and

deleted.

In the overkill dialog box, you eap #et object comparison, comparison precision (distance between objects) and
the object type. After selecting the options accandineetn, welect OK.

® . O o
| Object Cm\t
I _:_I /1 Ignore Layers Comparision Precision: 0.000001 1
o V] Ignore LineType % //O
7] Ignare Color T
[ I 1 = [ Igonore Lineieight P
‘ \@ Ignore PlotStyle §) < @
=
[ ] I Object type(Lines Arcs and Piines) and overkil style 2 [ I KS}
7]Pines - Opbmaze segments within pines ¥ B N,
' ' ® (0
Ei Ej V! Overlap - Combine co-inear objects that partially overlap i [ J
7]End to End - Combne co-inear cbjects when aligned end to end i \
x
i
— | &
\
Lo ) (Lo | ®
Block - . Block
duplicated | duplicated
millimetrically @ ! deleted D)

Multiple Cop@opy multiple objects with Repeat, Array, Divide and Measure options.

MenuExpress tools>Modify>Multiple Copy
Command Ent©PYM

Start the command and the command line promptSas folidyecSelect the objects to be copied

Base poir8pecify a base point

Second point or [Repeat (last)/Divide/Measure/Array (dynamic)/|Seletckaseeond point or any option

Options:

RepeaRepeat the last copy usingriteedstset distance.

DivideLinear divide option. Prompts for an additional point and the number of copies to make. Makes evenly spac
copies of the selected objects betwleasetpeint and the second selected point

Repeat Divide
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Measurdinear measure option. Prompts for an additional point and the distance between copies. Makes evenly s
copies at the specified distance between the base point and the second selected point.
ArrayDisplays the Arrgyi@hs prompt.

Measure Array

Layout By Padnlike common array function, LayoutByPath distributes object copies along a path (curve) with a vz
of array options. Users can dla@osidom, division and measure options and array in different directions along the
path.

Menu:Express tools>Modify>Layout by path Command Enthayouthbypath

For example, on mapping drawing, we can a
tool to array tiscontinuous central axis of the |
road or highway as shown in the picture:

=%
After started the command Layoutbypath, a A —

V LAYOUTREGENCTRL

will display in the command Hiezse select tlf////z_»_' -
object to array: I "

After select the object, a prompt message will display:
Please specify the base point:

The base point is the point where you want to start doi
from the object. We can select thé &wd Ipoint of this
object:

After select base point of the object, a prompt message will display \ ’

Specify the objectds directi orm,.d,mmm/)?r ve<Y a
This message is important bece Er . \\mwm“‘*“‘iﬂi pl ay w
along the path. Because we select the end low point of the object ¢ /

we lave to specify a parallel point direction to keep the object parall \
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path (long green line):

After specify the objec
display:
Please select the curve:

Then select the long green line. This line is the curv —

that the object will follow.

After select the curve or path, a prompt message will
Specify select along which side of the curve <left side
forward

direction>: This
message is also important because we will specify th
which the object will be array. For example, we speci -~
side of the curve as shown in the picture.

After specify the sideetthive, a prompt message will displayt the method Random (R) / Division (F) / Measure
(D):

There are three options random, division and measure:

Randonmhi s all ows to array the selectednealbj ect al ong
DivisiornThis allows to array automatically the selected object along the path by inputting the number of objects.
Measurérhis allows to array automatically the selected object along the path by inputting the distance value.

For example, ifaeenot know the distance between objects but we know the objects quantity, we can select the opt
Division:

After select the option, a prompt message will
display:
Enter the numbAmd we enter the value 11

After enter the value, a prompt messhsaayill
Pick a point on the curve as start point (Distrib ——"

the end curve when selection is empty) [Pick = point on the curve o start point(Distrbute from the end of curve when selection is empty): ][220 |[< 230" |
Then pick one of the end points of the curve:

After pick the point of the curve, you will get accurg
result: Ahalso you can repeat the same array opti 7 L
the other blue central axis of the road. - — S~ —

Flatten Objec@onverts 3D geometry to a projected 2D representation.

Menu:Express>Modify> Flatten Obje€smmand Entfjatten
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7. Draw Tools
SuperhatchHills arenclosed area or selected objects with a hatch pattern, solid fill or gradient hatch.

MenuExpress>Draw>Superhatch
Command Enfytperhatch

The Superhatch dialog box is displayed: Superhatch =5
ImageAccesses the Select Image dialog box to specify the image for th
pattern. BlockOpens the
Superhatch_Insert dialog box to specify the block for the hatch pattern.
xref AttaciAccesses the Select reference file dialog box for specifying a

a hatch pattern.
WipeOuSelects a wipeout object as a hatch pattern.
Select Existir8glects an existing image, block, xref, or Wipeout as a hat

For Images:

1. Open Superhatch dialog box.
2. Click Image... button, choose an image fi

the Superhatch Imageraster dialog boxis| =
d is p I ayed . Position: F:\GSTARCAD\PRODUCT LINE\PLATFORM\GSTARCAD PROTO
3. Pick the OK buttdheérSuperhatch . e -
. . . g | gpedftomcers || gy Paancis
Imageraster dialog box, specify insertion | o | —
scale factor and angle of rotation. . =
4. Ther ompt ol s the p| =
acceptable? [ Yes/ Ng =
5. Pick a point in the rectangis, PRTER to
finish. .
Superhatch_Insert [ 28 o
o Defined Blocks - ﬂ
For Blocks: i o -
Options
1. Open Superhatch dialog box. 1 ety rencers on e N
2. Click the Block... button to access the e [T % (1000000 | angie:  [0.000000
. . | 0.000000 y: | 1.000000
Superhatch_Insert dialog box: = ] G Seecon; V50
. = F L -“ -_ance\
BlockClick the Block... button to select a t :
. .
in the current file.

FilePick the File... button to select a drawing file as the block
3. Select éhblock in the Defined Blocks dialog box NN
press OK. “

4. Specify insertion point, scale factor and angle ‘\

rotation. K‘

5. Thepromptl s t h e hsIMAGEasteptab \\“
[ Ye s/ Nads|displayed. €kioose No to Esc. Ify (\%l

Command Line
ICommand: SUPERHATCH
%\ HnsertErter block name or [?] <NEW BED3: NEW BED
AR [Unit: Milimeters convert: 10000
|Specify insertion point or [Basepoint./Scale.X/Y/2/Rotate]
[Enter X scale factor, specify opposite comer, or [Comer/XYZ] <1: Enter Y scal
] [ factor <use X scale factors:
\ (Speciy rotation angle <0>:
ISpeciy insertion point
[Erter X scale factor <1.000000
lease appoint the rotate angle:
I the placement of this BLOCK acceptable? [Yes/No]<Yes>Y
lease appoint the first point
ICommand:
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choose Yes, GstarCAD will ask you to specify the first point and the next point to place the image.
6. Specify an internal point of the objects for hatch boundary then press ENTER to finish hatch

EOL\:ZLP;O ;;:perhatch dialog box r'"-'"-"'-l Superhatch
gl ke,

click the Wipeout button: 2o
2. GstarCAD will ask you to spec %
insertion point to create an area f .

[

Xref Attach,

masks underlying objects N
3. Press ENTER to finish creating the ‘
boundary that masks underlying objects.

4. As shown in the picture, move thivdeto the carpet, the block will automaticaily
cover the object under it:

Select Exiting...

[

S B e

glll LN e e AN AN e e

Breakline Symi@reates a polyline and inserts the breakline symbol. The options within this command are provide
control the relative size and appearance ofribesynetadd and an extension of the polyline beyond the selected start
and end points.

MenuExpress tools>Draw>Breakline Symbol

Command EnBREAKLINE . Structural Detail
. GO0

Once start the command, the colimagmdmpts as follow: IR Y )

_ _ S =pcicotes
Block = BRKLINE.DWG, Size = 1.000, Extension = 1.250 . L}
Specify first point for breakline or [Block/Size/Extension/sPelgify line 10000  EEEEE W
for breaklinSpecify a point, or enterreptio - Structural Detail

Eeeod

Options:

Specify first point for brezRiiaws break line through specifyirg, T 22 %
its start point and end point. —

10000

Structural Detail

o0
BlockDetermines the block to be used as the breakline symbgl.——
Enter the block name for breakline symbol <BRKLINE.DWES-@Gd¢-
Enter a block name and press ENTER or press ENTER. If yoii press

_ 10000

ENTER directly, the saving path of the break symbol file wil-se
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displayed on the command line. Structursl Detsil

6606
SizeDetermines the size of the breakline symbol. ==t
Breakline symbol size <Specify the size of the breakline symba ..o, 060

E oD i ing L

x_tensmetermlnes the length of the lind@xtezyond selected E Stroctural-Detai 222
points.
Breakline extension distance <1Speeify the extension distanci.. | & & @O
Once the start point for the break line or the setup break symholis .~ -
assigned, the command line prompts as follows: Erheeo- ‘
Specify second point for breSpetify a point

10000

Specify location for break symbol <MidSpecify the point on the
line segment to specify the location of the breakline symbol, or press ENTER to use the midpoint of the line.

Spline to Lin€onverts spline(s) to numbers of straight lines.

MenuExpress tools>Draw> Spline to Line
Command EntBPLINE2LINE

Once the command is started, the command line prompts as follow:

Select spline or [Set parameteSE):ect spline(s) or input 0S6 to set
[The line precision/Starting point (S)<1l6puf:a new value bigger than 0 to join precision betwe@esegment li
Conversion in a straight line to allow the greatest number tiput@few value smaller than 5000 to number of
lines

At first, the system will fit the spline with a se
number needed is more than the maximum number, the system will extend the length of the lines by force, using
maximum number oSlinfit the spline.

Select spline or [Set parameteT$@n]|select the spline(s) to be converted and press Enter to finish the operation

—

.I ina ST i 0 ke the et mambe of <500 |13 I . ',r-
..-I / \/ .\\J’/, = - .

Spline to Plinw/ith this tool tB&line created can be converted to a polyline according to the accuracy (humber of
segments of the arc) that the user assigns. The more specified the segment number is, the higher is the matching
between the converted Polyline.

MenuExpress toolsx@w>Spline to Pline Command En®RTPI

For example, draw the follow spline sample with 5 arcs as sh

34 5 ARCS IN THE SPLINE



After the command SPTPL is, stértext select the o(Spline).

After selecting the object, a prasgage will be displayed > < -

Delete the spline? Yes(Y) / hotihig: case, if we select Yes, t 3

option will delete the spline in place but if we select No, it 6

the spline. After inputting the delete sp .
option, a prompt message will be dispidgede enter the 1 4 8

number of arcs NmmoAnd we have to input a value higher 8 SEGMENTS CREATED IN THE PLINE
zero, for example 8. This value determines the segment number of
arcs to be created in the new Polyline.

Line to Plinghis function can convert one or multiple connected straight line(s), arc(s) Yolonarpabdiees

from:

MenuExpress tools>Draw>Line to Polyline
Command Entrine2pl

After starting the command, a

prompt message will be s In this drawing there are many lines
displayed=Please enter the join 4 \\ //\\\‘ /F\_
precisiord _(__{i;[zfj‘ _____________________ },t\m:]_
The Join precision will determine’, / % o

the union space between end o R P ]

points of each object. In this case,
we will input value 0 to ensure the connection between objects (lines).

After inputting the join véllemse select the objectsdmbeeand converted to Polyline:

In this drawing there are many lines

|
i
i ;
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8. Tools
Command Aliad his function allows users to add, modify, delete command alias and shell commands.

MenuExpress tools> Tool€ammand Alias
Command En#iy:IAS

Operatlon Steps "~ GstarCAD CommandAlias B8] ,
. File Edit Help Edi C d Ali
1. Start the command and a dialog BoX e« swi comsn ]
1 staiCAD commands entered from shartcul T he ali d its ICAD d
will pop up. ==l
2.Select commands to be deleted|andis SDoRBIT 1l = ‘A'ai:& e
- 3DFACE
click OoORemoved puitof" to del eftle swoo '
. A4 AREA g : Gapeal
command alias. s, L | SRR (==
1 ACADWBLO... WBLOCK 3DARRAY A‘
3.Select the command to be modified ot  socenten DFACE =
AL ALIGN v
and cl itokadaghbi t b b u > B |
. ADCENTER 9
will pop up. (%] Conim changes

4. Click O0OKoOo tp_ fi “ting.

System Variable Editcllows you to view, save, load and compare system variable settings.

MenuExpress tools> ToolSystem Variable Editor
Command En®By.SVDLG

New Value: (Read-only]

. . ) _Pngﬂi Current Value: g goon
System Va”ables Dlalog BOX OpthﬂS p_‘\\éf?DNUUT%ER - Initial Value:

ADCSTATE
AFLAGS SavedIn  Not saved Type: Real
ANGBASE

DIR AREA is both a command and a system variable. The AREA system

LISt BO)DISpIayS a IISt Of SyStem Varlables The > (WDX variable stores the last area computed by the AREAcommand. Because

APERTURE entering area at the Command prompt invokes the AREA command,

f|e|d above the I|St box a”ows for flltenng the || W you must use the SETYAR command to access the AREA system

ATTMODE variable.

display badeon user input. For example, entering iore.
DIM* in the edit field filters the list to display only 4Rec

. ) i BACKZ [ Save All... ” Read... H Compare with saved H 0K H Cancel]
system variables that start with DIM. If nothing s|eereE
D RS

entered in the edit field, the list displays all syste

variables. If more than one system variab@ghtedjgtiliedit and display options are unavailable.

New ValubBisplays the current the list box as if SYSVDLG was Saved liDisplays where the value
value of the system variable started. of the highlighted system variable is
highlighted in the list box and allows saved.

you to edit that value. No Changes|l’]itia| ValuBisplays the initial value

are committed until the dialog is  Of the system variable highlighted irypeDisplays the type of the

closed with the OK button. the list box. This is the value the highlighted system variable; for
system variable has in a new example, integer, real, string, and so
Current ValiRisplays the value of drawing. on.

the system variable highlighted in
Save ABaves the currergtem

variable settings to an SVF or SCR
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file. SVF files can be read into  depending on the condifitimeo with the Cancel button. SYSVDLG

SYSVDLG and SCR files are system variable list. will validate new system variable

AutoCAD scripts that can be run values as they enanged.

from the AutoCAD command line. ReadRestores saved settings from

The button will display Save All, an SVF file. No changes are savedtonpare with sa@ompares the

Save Selected or Save Filtered the drawing until you choose OK. Adlriables of the drawing with the
pending changes can be discardedaved SCR file.

¥ MKLTYPE-Select Linetype File E
@@q < Loca... » GStarCAD2012 Professio... > v [ 4 | search Gst 55
(2 A

Organize v New folder

. B Videos “ Name
MenuExpress tools> Tools >Make Linetype & a8Te

Tablet

CommanéntryMKLTYPE

y

s Local Disk(G ToolPalettes
s Local Disk (D)
s Local Disk (& _
= Removable D

Make Linetyf@reates a linetype based on selected objects

UserDataCache
VvBA

[@1cap

[z 1caDISO

Once the command is started, the following window will bjf . =~ oo
displayed. You can find the Line files (*.lin) and apply ther E

Save as type: |Lin files (*.lin) v
current drawing.

4 Hide Folders Cancel
_————

Make Shap@reates a shape definition based on selected objects.

MenuExpress tools> ToolMake Shape
Command EntiKSHAPE

Attach Xdaisttaches extended object data (xdata) to a selected object.

MenuExpress tools> Toeléttach Xdata
Command EntRATA

List Object Xddiists the xdata associated with an object.

MenuExpress tools> Toelkist Object Xdata
CommanéntryXDLIST

Break Point Chdtkan mark unclosed endpoints among selected lines, polylines or arcs, and close them immedia
when prompting that the area is not closed when hatching, calculating areas, or creating regions

MenuExpress tools> TooBreak Point Check
Command Ent®y:OSELINE
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9. Table Tools

Table Fill INou can use this function to fill in the table or edit the texts.

MenuExpress>Table Toolable Fill In
Command EnfFf@RMTXT

Operation steps:

1. Start the command.

2. Click in the cell or
3. In the dialog box you can set the text height fashion,
fashion and other textwtsb

Fixup Text High: 45

Change Text High

Just Space between;

Text High Fashion: Measured word high | Just Fashion: i

[] Change TestJust

Cancel

4. Click the blank area of a cell and input texts directly.
5. Enter to finish filling in.

Draw TablEhis function can help you draw a table.

MenuExpress>Table Tools> Draw Table
Command EnB@GE

Operation steps:

. Start the command.

. Specify the first point of the table.
. The command line prompts.

g O O T 9 WDN PP

. Specify the second point to finish drawing the table.
Merge CellFhis functias similar to merge cells in Excel.

MenuExpress>Table Tools>Merge Cells
Command EnB@H

[Cancel

(Q)increase level width /(W)minish level width /(A)increase vertical high /(S)minish vertical high /(D)input width and highspecify the second orientation poin

t of form(cell widthl6,cell highB,columnl3,row-13):

Operation steps:

1. Start the command.
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. Press Q key and the width of the form will increase a little, is used to adjust the horizontal width.
. Press W key and the width of the form will decrease a little, used to adjust the horizontal width.
. Press A key and the height of the form will increase a little, used to adjust the vertical height.

. Press S key and the height of the form will decrease a little, usedrticabpeigtiie

. You can input the corresponding options to adjust the size of the table.

0g
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2. Specify the borderline of the form to merge or the first céiélew.shown
3. Merging effect as betad. press Enter to finish the command.

Samplel: Specify the borderline of the form

Sample2: Specify the first cell and another cell

[Specify the first point of the form {enter’:

Specify another cell:

Split Cellsthis functionganilar to split cells in Excel.

MenuExpress>Table Tools>Split Cells ﬂﬁ:i

Command Enﬁﬁ% FG 3 Column * 2 Row ‘

Operation steps:

1. Start the command.

2. Specify the cell which needs to be split.

3. Move the cursor, when the rows and columns are a size up
click the mouse and #ikevall be split automatically.

Add BiagThis function can add bias for a cell.

Click the start and end point according to the prompts and the system will provideprandarae aasilgn

find the start and end point of the bias, or you can click any area in one cell and the system will find the top left pc
the cell automatically, then the system will prompt you to select the end point, you can atke cldlk any area in
system will take the bottom right point as the end point automatically, this way, a bias is added in a cell.

MenuExpress>Table Tools>Add Bias
Command EnBX

Operation step

1. Start the command.
2. Specify start point, you can click the top left pkintor cic
the blank area in the cell.

3. Specify end point to finish drawing the bias.
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Drag Multiple Lin¥eu can change the row and column width by draggingethabie@od tthe corresponding
parts of the line will also change. For example, drag the line you selected to the right side and all the lines in the r
side will move to the right side correspondingly.

MenuExpress>Table TodBrag Multiple Lines
Command En®GMT

Operation steps

1. Start the command.

2. Specify the line of table for dragging.

3. Specify the place or distance to drag to (left is positive).
4. Enter to finish moving.

Drag Lin®ifferent to Multiline drag, Drag line will just move the line you selected and other relevant lines will not n
MenuExpress>Table Tools>Drag Line
Comman@ntryBGST

Operation steps

1.Start the command.

2.Specify the line of the table for dragging.

3.Specify the place or distance to drag to (left is positive).
4.Enter to finish the command.

Drag Segmeihis command will cfzainge the lines of the whole table, but just move the side line of a cell.

MenuExpress>Table Tools>Drag Segment
Command EnBGJT

Operation steps:
1. Start the command.
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2. Specify the line of the table for dragging
3. Specify the place or distance to drag (left is positive).
4. Enter to finish the command (Fig24).

Selection Scalhis function can zoom in and zoom out the whole table base on the point you specified.

MenuExpress>Table Tools>Selection Scale
Command EnB%SF

Operation steps

1. Start the command and specify the base point for the line of table.
2. Move the cursor and the table will zoom.

3. Drag to a suitable position and click.

Intersectionfopacy point for the li:

Add Rowrhis function can add rows to the table.

MenuExpress>Table Tools>Add Row
Command EnBy3ZH

Operation steps:

1.Start the command.

2. Specify the position of the new row.
3. The system will add a row below the point you specified.

Add Columthis function can add new columns to the table.

MenuExpress>Table Tools>Add Column G—
Command EnB@GZL

Operation steps:

1. Start the command.
2. Specify the direction ofevecolumn. L
3. The system will add a new column on the right side of the table.
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Delete RoWhis function can delete the row of the table you specified.

MenuExpress>Table TodBeslete Row

Command EnBy3SH

Operation steps:

1. Start the command and specify the cell of row for delete.
2. The system will deleterow you specified.

Delete Colunhis function can delete columns you specified.

@

MenuExpress>Table Tools>Delete Column

Command En®B%SL

Operation steps:

1. Start the command.

2. Specify the cell of column for delete.

3. The system will delete the column you specified.

Delete TablEhis function can delete the table you selected.

T T
Opposite corner: I "( 156° I

MenuExpress>Table Tools>Delete Table
Command EnB3SC

Operation steps:
1. Start the command and specify the table for delete.
2. Enter to finish deleting.

Text Orientation Adjigfunction is used to adjust the alignment of the texts.

MenuExpress>Table Tools>Text Orientation Adjust
Command EnBJS

GstorCAL GstorCAl GstorCAL

GstarCAL GstoarCAL GstarCAL

Operation steps:
GstarCAL GstorCALl GstorCAL

1. Start themmnand and select the text for adjust. Command gar

Command: BGIS

*Text orientation adjust*-Bgjs
Select the text for adjust:

Select objects:Find out 1, total 1
Select objects:

Enter new justification...(® Center,1 Left,2 Right,3 Both)<flush center>:
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2. Press Enter and the command line will prompt the location mode.
3. Here we input 016 to select | eft alignment.
4. The text you specified will align to the left, as shown below.

GstorCAL  GstorCAIL GstorCAD

GstarCAL GstorCAL GstorCAL

GstorCAL GstarCAl GstorCAL

Notice:

1. This function can only orient and adjust the table text in the TABLE layer.

2. The distance to the table line ushgrefent or right alignment has already been set by the program, if you thunk
that the distance is not suitable, you can use the GstarCAD command to adjust the distance.

CAD Table to ExEhis command will convert sheets, composed by line/Sghtextnd @A&D, to EXCEL.

MenuExpress>Table Tools> CAD Table to Excel
Command EntBC_CTE

@@ CAD Tableto EXCEL  (BmESew

Operation method:
1. Start the command and specify the conversion ratio.

2. Select the table thad t@&e changed and press enter, the system v Hi
automatically open EXCEL after conversion. :1;3
3. Save the EXCEL sheet.

Table Scale: Ad

1

_1"'l2 3

PART LIST A
" PARTUST

| GSTARCAD s s [l o [eu[ " aSTARCAD

(™" BMW CHASSIS CLAMP I 11 ] -
ASSEMBLY - . 1 BMW CHASSIS CLAMP

ASSEMBLY

" U BWMCP-10006394 |
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10. Coordinate Tools
Export Coordinétiés easier to extract coordinate data frgwita@@EXPORT innovative tool.

Menu:Express>Coordinate Tools>Export Coordinate
Command EniyMCOORD

You can pick as many points as you need from your drawing and export ddtthtocodrdinats file. This tool
could be applied conveniently on planning, surveying, mapping, and construction drawings.

Execute COEXPORT command and select what format (.txt/.xIs) you want to save the file.Then pick all the coord
points on ypaurrent drawing. Each time you pick a point, its data will be automatically storage in the file you selec
To finish the process, press Enter. You can open the saved file and check out all coordinate data (X,Y,Z) extracte

File name: Coordinate Data Analysis

Save as type: [‘)ds

Al - X
A
1| X | Y z
2 4166.793 3581.064 0
3 4176.993 3596.544 0
4 4196.193 3632.784 0
5 4221.512 3620.664 0
o 4216.473 3611.184 0
7 4241.552 3562.824 0
8 4244.793 3552.624 0
9 4100.673 3519.264 0
4067.073 3553.104 0
4033.953 3540.264 0
4018.713 3551.304 0
4111.473 3699.864 0
4129.713 3689.784 0
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Coordiate PoinDimensions the point coordinate in the drawing.

Menu:Express>Coordinate Tools>Coordinate Point

Command EniyMCOORD

ICurrent settings: Auto = On, Control = All, Combine = Yes, Layer = Yes
Current settings: Auto = On, Control = All, Combine = Yes, Layer = Yes
Current settings: Auto = Off, Control = All, Combine = Yes, Layer = Yes
finput dimension text scale<15.0>:5

linput dimension text high<8.0>:3

[Specify the coordinate point <Bxt>:

Unit: Unitless convest: 1.0000

[Enter attribute values

[Specify the coordinate direction Or [Change Parameter{Q)j<Enter>:
[Specify the coordinate peint Or [Change Parameter(Q)j<Bxit>:"Cancel™
Current settings: Auto = Off, Control = All, Combine = Yes, Layer = Yes
Current settings: Auto = Off, Control = All, Combine = Yes, Layer = Yes
Current settings: Auto = Off, Control = All, Combine = Yes, Layer = Yes

i

ICommand: 4 [

Change Z Coordir@haose several objects dinoa@nd then

change the Z coordinates together.

Menu:Express>Coordinate Tools>Change Z Coordinate —_

Command EnttydANGEZ
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Command: _CHANGEZ
[Select objects to change high <Enters:
[Select object: 1 found

[Select object

lnput new Z coordinate <0>:10

Command

N

[ohanged 1 bjects Z coordnate



11. Drawing Tools

Graphic Compafs we know the drawing compare function in GstarCAD can be used to compare similar draw
containing nearly number of drawn objects to each other, especially to compare different versions of revision drav

OCREVEdwg ¥ OCREVAGwD

B 0crEvRdng =5 o | Socanumy =)

Mol oyt Lt Moo sy il
MenuExpress tool®rawing Tools>Graphic Compare AN =
Command En'[m:MP OldDWG: :PLATFORMIGSTARCAD 2017\G17 FEATURES DWG\DCREVA.na [ promse

New DWG: F:\GSTARCAD\PRODUCT LINE\PLATFORM\GSTARCAD 2017\G17F [ Browse

CMP Result,

Drawing compare can make comparisons between twozsiunilar

drawings (old DWG and New DWG) and generate thém as

separate files. After pressing COMPARE button within “= (== o=/
CompareDwg dialog box, the prograrmeséitegand opefi===== ==
_old and _new.dwg files, where you can see the diffef&8fge&™ = "o 1w

i [@llayer [ plot width ! ety E‘ g
between drawings. e e -

Drawing Compare can find out differences (drawn objects).andente o ok
show the result with different colors, e.g. if a line is modified, ==
removed or newly drawn, it wifdayed in different colors.”

|, L,

Model ; Layoutl | Layoutd Model ( Layoutl | Layoutl

But there is something else that drawing compare

could not accomplish so accurately. Drawing -
compar e candt insertfjan:d'-s_
objects on the current drawing working space that i o il ST

you are working at remé.t Besides, drawing—— — i :

compare candt show the 'detalids of—hA.l)w the objects
were |located before they were modified. DC REVISION "A" o DC REVISION "8" o

w the compared
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So the details are very important when comparing objects. Now the new and innovative Graphic Compare too
more! It does not only contywardrawingswith similar objects geometry and find out the differences but also displa
the details of any change at the current workspace of your drawing in real time, e.g. if a line is modified, only the ¢
part of the line is displayed in diffel@n{The unchanged part remains unchanged.

Graphic compare dialog box
You can invoke the Graphic Compare dialog box by tipping OCMP command at command line or by dynamic inpt

. . . = Drawing Compare @
Specify Drawin@®©fferstwo options of draw secsdming

comparison between sedbtcts on your currg oo
drawing or specify files.

Select ObjecOffers two options of objects selg
including their base points to be compared.
Select base objects and baseThisnoption allow
select all objects, including a basis poinirsts e

selection set to be compared. © Inset curent document ) Exportto afie [_Oupssstings )
Select compare objects and basEhisioption allow
select all objects, including a basis point as a

[ Select base objects and base point J ﬂ No object selected

|Select compare objects and base point } ﬂ No object selected

(7) Specify file

CAUsers\asus'\Documents\ocmp .dwg

selection set to be compared with the first select Lo [om | [ )
= Output Settings

Specify Fil€heckingthis option allows/se two drawing file tg e e

compared known as base and compare file. T [0 -
Color: (O Yelow -

Output Drawi@ffers two options of drawing compared outpy |, ... [ rmp—
Objects only in the compare drawing

Insert current docuniEhmis option allows insert the compared (s o 7

selected objects on the current workspace. Color: (WRed -
Linetype: [ ———— Continuous_ ~|

Expdrto a fileThis option allows output the compared set of |  concidence objects

objects to a drawing file. Layer o z)
Color: (MColor 8 v

Output settinygu can setup properties like layer, color and| tnetype: [ ———— Continuous_+|

for all selected objects to be compared to enhance visual

Ok Cancel
between them. [ ) Loma )
Inserting Compared Objects Set into Current Drawing
To insert compared objects set into current drawing, first seectydewng

@) Select objects
buttorbelect base objects and baseTh@ntselect allobjects :
. i . X |{ Select base objects and base point ] 35 objects selededl
first selection set called base objects and specify a bas :

IESelect compare objects and base point | 41 objects selected l

the base objects.Then select theSaldtdrcompare objects e. .=
base poi@nd repeat all previous process mentioned above.
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e e 'l 4? Specify the base point: _I 283.2361,1142.7652|
DC REVISION "A" DC REVISION "A"

Under Output Drawing, check the lopgoin curren Oupu draving
document!f you want setup visual properties fc 2 Eeiane
compared objects, click Output settings button. Afte "~ 2 S T ST
can place the compared objects set in a conveni
according your need.

| 2 B} e
HEEE £y HRER /i
R A T
| WEUTA | :
o = - ‘:f?” 2 L3
" . /
- paa’ /
DC REVISION "A" DC REVISION "B" COMPARED
Drawing Compda: awi ng compare is an exclusive function in

requirement.

It enhances collaboration by usirgottEdrdisplays to show items on a drawing that have been changed, added, or
deleted byther members of the design team. Changes to items such as styles, block attribute, object of block can
be tracked. The program will analyze the differences between two drawings automatically. Then the differences w
marked with differentcolordJ s er s can al so set the marking color b

Menu:Express tools>Drawing Tools>Drawing Compare e %
Command Entwp Old DWG: D:\ORIGINAL DRAWING.dwg
New DWG: b:WUDIFIED DRAWING, dwg Browse

Once the command is started, the following window will be gisplayed:

Result Path: |D:1\ | [ Browse

[comwe | [Lopton | [ conce |
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In this window, you haverowse the old DW compareopion I

(original drawing) and the new DWG (d|| cmePreson: 0.0001 - Marll;color(did<d1ange)
. ) Cmp detail Old DWG New DWG
modified). You can also assign a path to s Haye  Hotwidth | BN B
compared drawing. Then select the button Cl|  @wo  @ifntstie I e modfied

setup the comparison parameters. Wline type  [7]entin block | no modifed

After setting up the comparison parametss SN MUYSU e
; ; | Qi |
colors, layers, line type, etc. select Ok to | U
these parameters. Note: Pay attention to t
color because the deleted, modified and —A
N T Classroom

= |

objects will assume these into the con
drawing. Then select the button Compare
window belde compare both drawings.

C1521 b
il iy ]
fompaetie =8 M| 5~ cea cz721
0ld DWG: D:\ORIGINAL DRAWING. dwg Browse
New DWG: D:\MODIFIED DRAWING.dwg Browse v ED e > 3600 Mogao
2] / < Bl |
[¥] 5ave Result =
R.EsuitPaﬂ‘:‘D:\‘\ | [ Bromse 'E; ; |
o) -
(A R T R = ' = Teachers
‘ m— 2F Room
‘ f A331F
) —
|
|
C1521
C1515 N

(T T ST C2721

Drawing Lod®ocess some objects or the entire drawing into an uneditable state, and add the function of setting a
password to lock the objects. The processed drawing can be browsed and prirdedpgassthot bdited.

MenuExpress tools>Drawing Tools>Drawing Lock
Command Entr@CKUP

After enabling tt@CKUfmmand, follow prompts are displayed:

z0 [m | L. ) = =
@ { | L b ]),'I-'

¢ Super ChangeZ Align List Viewport Synchroniz 3 £ Drawing Drawing Batch Batch Pdf
t Hatch Coordinate Space Scale wports  Compare Compare, Lock Unlock Print  Purge to Dxf

odify Layout Drawi

Obijects will not be able to béemadiér using this function, would you like to continue? [YEspfiriie(N)]:

whether to continue executing the command.
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Select ObjeSel ects objects that you want to lock in the

locked l&yr 6 prompt wi || be displayed in the command || i
Do you want to create a password [Yes(\Aske Whether to add a password after locking objects.

Enter passwdmputs the password you set for the locked objects.

Note:
1  The locked objects caselected as trim boundaries to
unlocked objects.

Block Reference

B Color Bylayer

f  The locked objects are turned into a block reference, 3 1

mml Linetype Bylayer

displayed on a temporary layer.

1  The locked objects can be select. A little lock mark dig
when you hover the cursor on a locked object.

1  When erating the ERASE command to delete the lock
objects, the del ete comman ted, an

a locked |l ayerdé prompt wil the co

1  Vesions that lower than Gstam@ABan not unlock the objects which logbaskwitid.

Batch Purge (Batch Files Cledhisgew function allows to batch purge the excess objects such as blocks, layers,
l'ine type, dimension style or text style on severa
command of purge directly, which makes it run with very high efficiency. You can access it from:

Menu:Express>Drawing Tools>Batch Pu@emmand EntBatpurge

After the command is started, a dialog box will be displayed. In this dialog kelegbwoarladd,clean and
start purging objects within DWG files with the following
options: EEmes 2w

Add FilesAdd one or more batch files from the sel
path.

Add FoldeAdd DWG files from a selected folder.
Select AlSelect all the DWG file listscat [
Select Non&Inselect all the DWG files at once.
DeleteDelete selected object(s) in the file list. Lo ] [ m
ClearClean all the DWG file lists at once.

Start Purg&tarts purging the selected DWG file list. After purging, GstarCAD will gefileratecsengepzah

see the purge details.

Log:After the purge operation is finished, you can Login in to the created notepad file and see the batch purge de
record.
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Move BAIChanges the destination folder for drawing backup (BAK) files.
Menu:ExpresPrawing ToolsMove BAKCommand EntOVEBAK

MOVEBAtommandhanges the destination folder for drawing backup (BAK) files. Once you specify a path,
drawingds BAK files is placed in that path after e
Enter new value for MOV&BAKnone <current setting>:

Enter a . (period) for none or type the folder name

If you enter ".", the MOVEBAK folder name is cleared and new BAK files will be created in the original folder.
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12. AutoXisTable

Create TableMenu:Express tools>AutoXIsTable>Create T@omand
Entry:CAOT_AUTOXLSTABLE_CREATE

opreLion Sepe
1. In the AutoXLSTablelpwth menu, click Créatde. = .

V= A &&-BDE}E-E g x A x|
isti - @ E(S=en | 2@ |TXFT =
2. Create an Excel spreadsheet or open an existing Excel sp, 7, = joews i3 © 20 5 0 jowe g | g o

Excel. SsTab
3. Click Finish button in the AutoXIsTalevputienu Excel.
4. Specify insertion point in GstarCAD.

9 - E SV -3

4 A . B C| D | E | F | 6 | H | 1
;7 PART LIST ABC- ASSEMBLY DRAWING REXROT

3 |ABC-REXROT 38 1 | CARBON STEEL

4 |ABC-REX- PT39 3 CARBON STEEL

5 |ABC-REX- PT40 1 | CARBON STEEL

6 |ABC-REX- PT41 5 CARBON STEEL

7 |ABC-REX- PT42 7 | CARBON STEEL

8 |ABC-REX- PT43 3 CARBON STEEL

9 [ABC-REX-PT44 2 | CARBON STEEL

10 |ABC-REX- PT45 10 | CARBON STEEL

11 |ABC-REX-TP321 7 | MILDSTEEL

12 |ABCREX-TP322 4 | CARBON STEEL

13 |ABCREX-TP323 1 | CARBON STEEL

14 |ABCREX-TP324 1 | CARBON STEEL GSTARCAD ABC.ASSEMBLY
15 |ABCREX-TP325 1 | CARBON STEEL REXROT
16 | DESCRIPTION | SERIAL | QT | MATERIAL |TREATMENT| OBS

17

Edit TablMenu:Express tools>AutoXlIsTable>Edit Table CEmmnardAOT AUTOXLSTABLE_EDIT

Operation steps:

1. Click Edit Table.

2. Select a table created by AutoXlIsTable in GstarCAD then the Excel file
will open.
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